Br-GoGo e PyInstaller

Ter uma aplicação leve e portátil e de fácil utilização pelos usuários finais é um sonho de todo programador.

Até então, todo o ambiente Blocos da Br-Gogo dependia de uma instalação completa do Python, dependências, além do Gtk.

Com a utilização da versão 2.5 do Python, não seria possível a utilização do PyInstaller. Tão pouco a instalação da versão 2.7 resolveria este problema.

Foi preciso mudar o processo de instalação do Python e suas dependencia para, a partir disso o PyInstaller funcionar, bem como gerar a versão portátil do ambiente Blocos.

O Manual do PyInstaller disponível aqui.

Anúncios